Overblog Suivre ce blog
Editer l'article Administration Créer mon blog
11 juillet 2014 5 11 /07 /juillet /2014 19:20
[Microsoft] - Propriétés disparues

Ca faisait longtemps que je voulais faire cette article. Maintenant, c'est chose faite !

Alors voila le problème : Dans les propriétés de l'ordinateur, les informations ne s'affichent pas correctement. Pour être franc, certaines informations ont simplement disparues !

En effet, dans la fenêtre des propriétés système, les informations concernant le processeur ainsi que la RAM ne sont plus disponibles. Ces informations sont récupérées par une requête WMI. Il faut donc que le service WMI soit démarré et fonctionnel.

Démarré, le service est. Mais fonctionnel ?

Et bien le test des propriétés système est un test très simple pour valider le fonctionnement de WMI. Si les informations s'affichent correctement, WMI fonctionne sans problème. En revanche, si le processeur et la RAM ne s'affiche plus, WMI est dans les choux, même si le service est démarré.

WMI HS ? Pas de panique ! Quelques petites lignes de commande et WMI sera remis sur pied. Sachez que ce problème vient de la base WMI qui se corrompt. Je l'ai eu régulièrement sur des serveurs Citrix qui requêtent beaucoup en WMI (Imprimantes, lecteur, ...). La seule solution est de faire un reset de la base de données. Rassurez-vous, rien de compliqué ni de dangereux. En effet, la base se repeuple immédiatement et est disponible avec toutes les informations.

Voici les commandes à passer dans une invite de commande (vous pouvez retrouver ces commandes sur le site de Microsoft) :

  • Désactivez le service WMI pour éviter qu'il ne redémarre : sc config winmgmt start= disabled
  • Arrêtez le service : net stop winmgmt
  • Passez la base en mode réparation : Winmgmt /salvagerepository %windir%\System32\wbem
  • Remise à zéro de la base : Winmgmt /resetrepository %windir%\System32\wbem
  • Réactivez le démarrage automatique du service : sc config winmgmt start= auto
  • Redémarrez le service : net start winmgmt

Une fois ces commandes passées, le WMI redevient fonctionnel.

Voici quelques copies d'écran pour illustrer cet article !

[Microsoft] - Propriétés disparues
[Microsoft] - Propriétés disparues

Partager cet article

Repost 0
Published by Lucky le Koala, le bien-heureux - dans Technique
commenter cet article

commentaires

Présentation

  • : Le blog de Lucky le Koala
  • Le blog de Lucky le Koala
  • : Le partage, c'est beau
  • Contact

Catégories